Azure has marked this incident as resolved, and Capella services are operational.
Posted May 29, 2026 - 22:40 UTC
Update
Azure Datacenter power and network infrastructure have been fully restored. The majority of services have recovered, with residual impact limited to storage-dependent workloads on two remaining storage stamps undergoing tail recovery. We are closely monitoring the situation and will provide updates as Azure shares further progress.
Posted May 29, 2026 - 18:32 UTC
Update
Azure teams are actively working to address the issue, with manual intervention and inspections ongoing to stabilize remaining scale units and restore full service. We are closely monitoring and will provide updates as Azure shares further progress.
Posted May 29, 2026 - 15:47 UTC
Update
Azure reported that mitigation efforts are still underway to restore affected network components across dependent services, including Storage and Compute. We are closely monitoring the situation and will provide updates as Azure shares further progress.
Posted May 29, 2026 - 14:35 UTC
Update
Azure reported that mitigation efforts are still underway to restore affected network components across dependent services, including Storage and Compute. We are closely monitoring the situation and will provide updates as Azure shares further progress.
Posted May 29, 2026 - 14:34 UTC
Monitoring
Azure has reported that mitigation efforts are underway to restore affected components across dependent services. Customers may begin to see signs of recovery as these actions progress. We are closely monitoring the situation and will provide updates as Azure shares further progress.
Posted May 29, 2026 - 11:13 UTC
Identified
Azure West US 2 region is currently experiencing degradation.Some Capella operations for resources within the region have been identified as impacted, we are continuing to monitor the situation.