Capella Operations Impacted by Azure East US Outage

Incident Report for Couchbase Capella

Resolved

This incident has been resolved as updated in Azure status: https://azure.status.microsoft/en-us/status. All the Capella services are operational in the East US.
Posted Apr 25, 2026 - 03:06 UTC

Identified

Azure East US Outage is partially impacting lifecycle operations, including new virtual machine creations, backups, and turn-on operations. Ref: https://azure.status.microsoft/en-us/status.
Posted Apr 24, 2026 - 16:48 UTC
This incident affected: Couchbase Capella (Couchbase Capella Operational, Couchbase Capella App Services) and Azure (Azure Virtual Machines).